PDF Help

Equity's forms and contracts were created in Adobe Acrobat. They are designed for use in only the latest (or very recent, back to v.8) versions of Adobe Acrobat or Adobe Reader – including Adobe 'Document Cloud'.

Third Party Applications

Equity does not guarantee any usability with any 3rd party PDF reader applications or utilities. Using 3rd party applications (e.g., Foxit Reader, Nitro PDF, or PDF-XChange) may corrupt the data in your PDF file and render it unusable/unreadable to anyone else.

Note for Mac Users

PDF files on your Mac may open in the ‘Preview’ application by default. Check the top-left corner of your screen to indicate which program is currently running, and ensure that the PDF file is open in Adobe Acrobat or Adobe Reader.

Internet Browsers

Every Internet browser handles PDF documents differently. Some browsers have removed their PDF support completely. PDF forms (e.g., fillable Engagement Contracts, Deputy PDF forms) with advanced features such as fillable fields, radio buttons, and signatures encounter varying and inconsistent levels of success. Therefore it is not recommended to use these contracts in any Internet browser.